• Inicio
  • Novedades
  • Academia SAP
  • FAQ
  • Blog
  • Contacto
S4PCADEMY_Logo
Twitter Linkedin Instagram
S4PCADEMY_Logo
Twitter Linkedin Instagram
FORMACIÓN SAP

Solución de errores comunes de replicación de datos en sistemas SAP

By s4pcademy 


Hay algunos errores que pueden ocurrir durante el proceso de replicación en los sistemas SAP que pueden requerir intervención manual.

En esta publicación, analizaremos estos errores y cómo responder a ellos de manera efectiva para minimizar el impacto en las replicaciones en tiempo real en las siguientes secciones.

Problema de llave duplicada

Si la carga inicial de datos se interrumpe debido a una interrupción planificada o no planificada, una vez que los sistemas involucrados en el proceso de replicación vuelven a estar en funcionamiento, SAP LT Replication Server intenta volver a conectarse automáticamente a los sistemas de origen y destino y reanudar el proceso de carga. Cuando esto sucede, el usuario puede encontrar un error: No se puede insertar un registro en el sistema de destino (error de clave duplicada).

Esto es exactamente lo que hace el sistema, ya que la parte de los datos se insertó en el sistema de destino, pero SAP LT Replication Server aún no sabe que la carga de datos se realizó correctamente antes de la falla del sistema. En consecuencia, cuando el sistema vuelve a funcionar, SAP LT Replication Server vuelve a intentar cargar los mismos datos, lo que genera el mensaje de error de clave duplicada. Puede resolver esto cambiando el comportamiento de escritura a Modificar matrizcomo se muestra en la siguiente figura. Para cambiar el comportamiento de escritura, inicie sesión en SAP LT Replication Server e ingrese la transacción LTRC. Seleccione el MTID y navegue hasta el Monitor de transferencia de datos pestaña, seleccione la tabla y haga clic en el Editar botón, que se encuentra en el centro izquierdo (icono de lápiz). Cambiar Comportamiento de escritura a 3 (Modificar matriz).

Se modificó el comportamiento de escritura a Modificar matriz

No se pueden replicar datos de la tabla XXX, existe una opción de activación diferente

Este error suele aparecer cuando el usuario intenta replicar una tabla del mismo sistema de origen a diferentes sistemas de destino. En general, para una tabla de aplicación (por ejemplo, la tabla SFLIGHT), SAP LT Replication Server comparte la misma tabla de registro y se activa cuando la replica a diferentes destinos.

La causa principal de la No se pueden replicar datos de la tabla XXX, existe una opción de activación diferente El error suele ser una diferencia en la configuración. Compruebe si la Permitir uso múltiple y Leer desde un solo cliente Las configuraciones en la configuración del servidor de replicación SAP LT son consistentes en todas las configuraciones cuando se planea replicar una tabla en diferentes destinos. Para ello, vaya a Transacción LTRC, ingrese el MTID y navegue hasta la Datos de administración pestaña, como se muestra en esta figura.

Ajustes de configuración

La tabla no existe o es desconocida

Cuando se activa una tabla para la replicación a través de SAP LT Replication Server, SAP LT Replication Server crea una tabla de sinónimos y una tabla de destino física. Cuando esta tabla de sinónimos o física no está disponible para que SAP LT Replication Server cargue datos en ella, puede esperar ver el siguiente error: La tabla no existe o es desconocida.

Cuando se encuentre con este error, asegúrese de que el sinónimo y la tabla de destino existan en el esquema correspondiente en la base de datos de destino. Puede acceder a la información de sinónimos desde Descripción general de la tabla pestaña en la Transacción LTRC o desde el Objetos participantes pestaña en el servidor de replicación SAP LT, según su versión de DMIS.

Problema de comunicación

Cuando se produce una interrupción planificada o no planificada en un sistema de origen o de destino, también afecta las operaciones de SAP LT Replication Server debido a su incapacidad para acceder a esos sistemas. En tales situaciones, es natural que surjan problemas de comunicación entre SAP LT Replication Server y los sistemas de origen o de destino, lo que genera fallas de replicación.

Cuando el origen y los destinos vuelvan a estar en línea y operativos, SAP LT Replication Server intentará automáticamente restablecer las conexiones, lo que permitirá que las replicaciones se retomen desde el punto en el que se interrumpieron. Para las actividades de mantenimiento planificadas (como cambiar el nombre de host del origen), es importante ajustar las conexiones RFC relevantes con los nuevos detalles del sistema después de la interrupción. Este ajuste es necesario para evitar que surjan problemas de comunicación.

No se puede crear la tabla de registro /1CADMC/XXXX; la tabla existe con una estructura diferente

Una tabla de registro contiene columnas clave de la tabla de aplicación junto con otras columnas de la tabla de registro estándar. Las tablas de registro suelen tener un nombre basado en números de secuencia (marcado por XXXX en la tabla de registro /1CADMC/XXXX, y también conocido como IDENT). Estos números de secuencia se asignan en función del contenido de la tabla IUUC_LOG_APPLTAB en el sistema de origen y la tabla IUUC_LOGTAB_ID en SAP LT Replication Server. Es común ver que SAP LT Replication Server utiliza el mismo nombre para una tabla de registro al replicar datos de una tabla de aplicación en el origen a varios sistemas de destino. Sin embargo, en determinadas situaciones, también es posible que el mismo nombre de tabla de registro se asigne a una tabla de aplicación diferente. En tales escenarios, verá el No se puede crear la tabla de registro /1CADMC/XXXX; la tabla existe con una estructura diferente Error. Cuando te encuentres con este error, sigue estos pasos:

  1. Compruebe la tabla IUUC_LOG_APPLTAB en el sistema de origen y la tabla IUUC_LOGTAB_ID en SAP LT Replication Server para ver si el IDENT se utilizó anteriormente en otra tabla y está obsoleto. Si está obsoleto y ya no se utiliza para la replicación, elimine la entrada de la tabla IUUC_LOG_APPLTAB en el sistema de origen e inicie la replicación en SAP LT Replication Server.
  2. Si hay una entrada duplicada en IUUC_LOGTAB_ID en SAP LT Replication Server tanto para la tabla original que usa IDENT como para la nueva tabla, elimine la entrada para la nueva tabla de la tabla IUUC_LOGTAB_ID en SAP LT Replication Server e inicie la replicación nuevamente en SAP LT Replication Server.
  3. Si IDENT no está obsoleto, lo que significa que la tabla de origen relacionada está siendo replicada actualmente por SAP LT Replication Server, entonces ordene la columna LOGTAB_NAME de la tabla IUUC_LOG_APPLTAB en el sistema de origen en orden descendente y tome nota del IDENT más grande.
  4. Ejecute la transacción SNRO en el servidor de replicación SAP LT. Luego, ingrese “IUUC_SHDW” para la Objeto y haga clic Mostrar los intervalos. Cambie el intervalo a un valor mayor que el indicado en el paso anterior.
  5. Inicie la replicación desde el servidor de replicación SAP LT.

Con estas modificaciones, SAP LT Replication Server asignará el nuevo valor IDENT para la tabla de registro y los activadores, lo que garantiza una replicación exitosa.

Nota del editor: esta publicación ha sido adaptada de una sección del libro. SAP Landscape Transformation Replication Server: Guía práctica por Prathyusha Garimella y Shashidhar Garimella.




Introducción al Monitoreo de Control Continuo en SAP
Previo
Gestión de documentos en SAP Cloud ALM
Siguiente

Madrid

Calle Eloy Gonzalo, 27
Madrid, Madrid.
Código Postal 28010

México

Paseo de la Reforma 26
Colonia Juárez,  Cuauhtémoc
Ciudad de México 06600

Costa Rica

Real Cariari
Autopista General Cañas, 
San José, SJ 40104

Perú

Av. Jorge Basadre 349
San Isidro
Lima, LIM 15073

Twitter Linkedin Instagram
Copyright 2022 | All Right Reserved.